Compilador

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Compilador

Mensagem  Cassimiro em Sex Fev 12, 2010 5:26 pm

Bruno
Tudo Bom ?

OLHA O QUE ACONTECE NA HORA QUE COMPILO MEU PROJETO ?
não to conseguindo compilar, e to precisando de fazer o projeto para apresentar !!!

----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrador\Desktop\Controle de Ar-Luz\Projeto.mcp' started.
Language tool versions: mpasmwin.exe v5.32, mplink.exe v4.32, mcc18.exe v3.32
Preprocessor symbol `__DEBUG' is defined.
Thu Feb 11 22:10:51 2010
----------------------------------------------------------------------
Clean: Deleting intermediary and output files.
Clean: Deleted file "C:\Documents and Settings\Administrador\Desktop\Controle de Ar-Luz\main.o".
Clean: Deleted file "C:\Documents and Settings\Administrador\Desktop\Controle de Ar-Luz\display_7seg.o".
Clean: Deleted file "C:\Documents and Settings\Administrador\Desktop\Controle de Ar-Luz\Projeto.mcs".
Clean: Done.
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F4550 "main.c" -fo="main.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
MPLAB C18 v3.32 (evaluation)
Copyright 2000-2009 Microchip Technology Inc.
Days remaining until evaluation becomes feature limited: 36
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F4550 "display_7seg.c" -fo="display_7seg.o" -D__DEBUG -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
MPLAB C18 v3.32 (evaluation)
Copyright 2000-2009 Microchip Technology Inc.
Days remaining until evaluation becomes feature limited: 36
Executing: "C:\MCC18\bin\mplink.exe" "rm18f4550.lkr" "main.o" "display_7seg.o" /u_CRUNTIME /u_DEBUG /z__MPLAB_BUILD=1 /z__MPLAB_DEBUG=1 /o"Projeto.cof" /M"Projeto.map" /W
MPLINK 4.32, Linker
Copyright (c) 2009 Microchip Technology Inc.
Error - could not find file 'c018i.o'.
Errors : 1

Link step failed.
----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrador\Desktop\Controle de Ar-Luz\Projeto.mcp' failed.
Language tool versions: mpasmwin.exe v5.32, mplink.exe v4.32, mcc18.exe v3.32
Preprocessor symbol `__DEBUG' is defined.
Thu Feb 11 22:10:54 2010
----------------------------------------------------------------------
BUILD FAILED






Link step failed. ?????
Este é o erro né ?
Mais qual é a sua solução ?
já tentei de todas as formas !!!
Me ajude !!
Abraço

Cassimiro

Mensagens : 1
Data de inscrição : 12/02/2010

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Problema com o linker

Mensagem  Bruno S. Avelar em Sab Fev 13, 2010 2:44 pm

Olá,

Para resolver o erro "Error - could not find file 'c018i.o'. " que está dando em seu programa basta abrir seu projeto com o MPLAB IDE, clicar no icone builde options, ao lado do disquete verde salvar, ir na tab directories. Em show directories for: escolha Libary search path. Clique em new e aparecera uma linha em branco com tres pontos na direita. Clique nos ... e escolha o caminho C:\MCC18\lib. Coloque aplicar de ok e compile novamente seu projeto.
Para que este problema não aconteça nos próximos projetos que você for criar basta ir no MPLAB IDE. Na barra de menus vá em Project Set Language Tools Locations. Abrirá uma janela com uma tree view. Vá em Microchip C18 Toolsuite e clique no + dele. Vá em Defaut Search Paths & Diretories e clique o + dele ,vá em Library search patch e clique nele. Em Location escreva C:\MCC18\lib
Pronto, basta dar Ok e seus próximos projetos não apresentarão este erro.

Espero ter ajudado.

Bruno S. Avelar
avatar
Bruno S. Avelar
Admin

Mensagens : 74
Data de inscrição : 26/07/2009
Idade : 33
Localização : Belo Horizonte MG

Ver perfil do usuário http://picminas.forumeiros.com

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum